Name: _____________________________________________ Start Time: _______ Finish Time: _______
Alias/Handle (if any): ___________________________ Email Address: __________________ Section: ______

Hands-On Project #5

Part I – The data from HOP #4

1. For this HOP, we will assume that the following reflects the results of your consumer research for HOP #4 (note that some of these items are purposely incorrect, so do not attempt to use them to check HOP #4):

<table>
<thead>
<tr>
<th>Base System From:</th>
<th>Dell Dimension XPS MiniTower</th>
<th>Gateway 2000 w/ MMX</th>
<th>MidWest Micro Office PC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name of Base System:</td>
<td>Dell</td>
<td>Gateway 2000</td>
<td>MidWest Micro</td>
</tr>
<tr>
<td>Cost of Base System:</td>
<td>1776.00</td>
<td>1375.00</td>
<td>1474.00</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Feature/Component</th>
<th>Dell</th>
<th>Gateway 2000</th>
<th>MidWest Micro</th>
</tr>
</thead>
<tbody>
<tr>
<td>233 Mhz Intel Pentium MMX processor</td>
<td>Included</td>
<td>-95.95</td>
<td>Included</td>
</tr>
<tr>
<td>512 Kb (kilobytes) cache</td>
<td>Included</td>
<td>Included</td>
<td>Included</td>
</tr>
<tr>
<td>32 Mb (megabytes) RAM</td>
<td>Included</td>
<td>Included</td>
<td>-20.67</td>
</tr>
<tr>
<td>(close to) 4 Gb (gigabyte) hard disk drive</td>
<td>-49.00</td>
<td>50.00</td>
<td>23.00</td>
</tr>
<tr>
<td>3.5” 1.44 Mb floppy disk drive</td>
<td>Included</td>
<td>Included</td>
<td>Included</td>
</tr>
<tr>
<td>12/24X CD-ROM drive</td>
<td>Included</td>
<td>Included</td>
<td>-32.00</td>
</tr>
<tr>
<td>16 bit Soundblaster-compatible sound card</td>
<td>Included</td>
<td>50.00</td>
<td>31.00</td>
</tr>
<tr>
<td>Stereo speakers</td>
<td>Included</td>
<td>20.00</td>
<td>5.50</td>
</tr>
<tr>
<td>17” SVGA PnP monitor</td>
<td>-139.00</td>
<td>150.00</td>
<td>118.00</td>
</tr>
<tr>
<td>2 Mb SVGA accelerated video card</td>
<td>Included</td>
<td>Included</td>
<td>-10.00</td>
</tr>
<tr>
<td>33.6 Kbps fax/modem or Ethernet network card (circle the one chosen in this box)</td>
<td>79.00</td>
<td>115.50</td>
<td>27.00</td>
</tr>
<tr>
<td>Windows 95</td>
<td>Included</td>
<td>Included</td>
<td>Included</td>
</tr>
<tr>
<td>Microsoft Office Pro 97</td>
<td>199.00</td>
<td>149.00</td>
<td>233.00</td>
</tr>
<tr>
<td>Mid-Tower Case</td>
<td>Not Available</td>
<td>Included</td>
<td>Included</td>
</tr>
<tr>
<td>“Non-natural” Keyboard</td>
<td>Included</td>
<td>Included</td>
<td>-2.50</td>
</tr>
<tr>
<td>Mouse</td>
<td>Included</td>
<td>Included</td>
<td>Included</td>
</tr>
<tr>
<td>Lowest cost method of shipping and handling</td>
<td>80.00</td>
<td>120.00</td>
<td>60.00</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Total cost of customized system from:</th>
<th>Dell</th>
<th>Gateway 2000</th>
<th>MidWest Micro</th>
</tr>
</thead>
</table>

2. Use these figures for this HOP! After you receive the results of HOP #4, you could redo this HOP using your own results if you are interested, but for the purposes of this HOP, you should use the figures above.
Part II – Starting Excel and Filling in the Cell Labels

1. Look in Start Menu Programs for “Microsoft Excel”, and click on it to start the Excel spreadsheet program.

2. You should see a display like the following:

3. The first thing to do is create the basic layout of the spreadsheet. Start by creating the first row of column heading labels. Use the mouse to move the pointer (which will become a cross as soon as it enters the grid area) to cell B1, indicated above, and click on it. Note how the cell is given a dark border, and its address appears in the leftmost cell of the formula bar. The dark-bordered cell is called the active cell.

Note: Throughout this HOP, you may make mistakes and wish they had never happened. Fortunately, Excel permits this through the use of an improved undo command, similar to the standard “Undo” in the “Edit” menu option. Pressing the button once will undo what you just did, pressing it again will undo what you did before that, etc. Conversely, pressing the button will “redo” what you just “undid”.

4. Type “Dell” (without the quotation marks) into the cell. You will see the letters appear both in the cell and in the edit area of the formula bar (the wide rightmost area). Note that three buttons also appear in the formula bar. They are the “Clear” button, the “Accept” button, and the “Insert Function” button. When you have typed “Dell”, click on the “Accept” button. The buttons will disappear, and the text will be entered into the cell.

5. Move straight across, repeating step 4 to enter “Gateway 2000” into cell C1, and “Midwest Micro” into cell D1. Don’t be concerned when “Gateway 2000” overflows C1 into D1. You will still be able to select D1 for “Midwest Micro”, although it will appear that part of “Gateway 2000” is obscured. (We will fix this later.) When you finish, that part of the screen should look like this:
6. Now we are going to create the first column of the spreadsheet. Enter “Name of Base System:” into cell A2. Don’t be concerned when it overflows into cell B2.

7. Enter “Cost of Base System:” into cell A3, and “Feature/Component” into cell A4. (Yes, we skipped the row containing “Extra Charge or Savings With:”. We’ll come back to it later.)

8. Continue on down the column, entering labels from the chart in Part I of this hop into the first column of your spreadsheet. Do not skip any rows.

9. After entering the column of row labels, enter “Total cost of customized system:” into column B of the next row (this should be cell B22).

10. Use the scroll bar to move to the top of the spreadsheet. Click on the header for row 1, shown on the diagram in step 5. The entire row should become highlighted. Now click on “Copy” from the “Edit” option on the menu bar, to copy the row into the Clipboard. Notice that a dotted marquee is placed around the copied row.

11. Move back down to the bottom of your spreadsheet, and click on the header for row 23 which should be the next empty row. Press the “Enter” key to paste the copy of row 1 into row 23. Go back to the top and note that the marquee is gone. This is a special type of paste used in Excel, and we will be unable to paste the same data unless we copy it again. We could have used the standard “Paste” from the “Edit” menu, but the marquee would have remained, and we could have pasted the same thing again and again.

12. Now we would like to paste the same type of information into only a few cells of the “Feature/Component” line (row 4). Go to the top of the spreadsheet and click-n-drag from cell B1 through cell D1. When you release the mouse button, all three cells in that row (but only those three cells) should be selected with a dark border, although the part of “Midwest Micro” which extends beyond D1 seems to go beyond the selection. A selection like this is often called a cell range and is notated B1:D1.

13. Now use “Copy” from the “Edit” menu to copy this cell range into the clipboard.

14. B4 is the first cell to which this range of cells should be copied. Click on it to select it, and press “Enter”. The new cell values should be copied into row 4 from this point on. You will see that it appears to cover up a portion of “Feature/Component”, but this is not actually happening. We will correct it shortly.

15. We still need to add two lines from the chart in Part I. To begin, click on the heading for row 1 to select the entire row. Then click on “Insert” from the menu bar, and choose “Rows” from the menu. A single blank row should be added above the current row. It will become row 1, and the remaining rows will be renumbered.

16. Add “Base System From:” to column B of the new row (which should now be cell B1).

17. Repeat steps 15 and 16 to add a new row above row 5 (the “Feature/Component” row) with “Extra Charge or Savings With:” in column B.

18. Insert a disk in the floppy disk drive and use the standard “Save As” option from the “File” menu to save your spreadsheet up to this point on your disk with the name “HOP5.xls” (Be sure to save it onto drive A.) The name “HOP5.xls” should appear on the title bar of the sub-window for this spreadsheet.

Part III – Adjusting Widths of Columns and Rows and adding Data

1. Now we need to adjust the cell sizes to display our data better. Let’s start by adjusting the width of column A by hand.

2. If you are restarting after doing Part I in another session, you should begin by using the standard “Open” option from the “File” menu to load the spreadsheet from your disk into Excel.

3. Use the vertical scroll bar to allow you to see the row with “2 Mb SVGA accelerated video card” in column A.

4. Slowly move the pointer to the dividing line between column heading A and column heading B. When you are in the right place, the pointer will change into a double-headed arrow. While the pointer is a double-headed arrow, click-n-drag the dividing line (which will show up as a lightly dotted line) to the right until it just passes the end of “2 Mb SVGA accelerated video card”. Release the mouse button to finish changing the column width.

5. You should be able to see that some of the cells in column A are still too wide to fit in the available space. To force them to use more vertical space when necessary, start by selecting the entire column A by clicking on its column heading.

6. Click on “Format” from the menu bar, and then on “Cells…”. A “Format Cells” dialog box will appear.
7. Click on the “Alignment” tab in the dialog box. A number of options will be displayed, among which is a “Wrap Text” check-box. Check the box so that it looks like this: [ √ Wrap Text ] then click [ OK ] to continue. The cells in column A should now be using additional lines where needed.

8. The remaining empty cells in columns B,C, and D are our data cells. The cells in row 3 contain text, along with many cells which contain “Included” or “Not Available”, but all the rest contain numeric values from Part I (Excel calls these constant values.) Click on cell B3 to select the first of the data cells. Enter the corresponding data from Part I of this HOP. Continue in this manner until you have filled in the rest of the data from Part I. Note that no totals will be entered at the bottom at this time (we will have Excel calculate the totals for us later).

9. Scroll to the top of the spreadsheet so that you can see row 3 containing the system names that you entered in the last step. Click-n-drag from column heading B through column heading D to select all three columns.

10. Point to the dividing line between column heading B and column heading C so that it becomes the double-headed arrow . Click and drag the dividing line so that there is room enough for “Dell Dimension XPS PC” to be displayed (you may have to do this several times before it is enough).

11. When you release the mouse button, all three of the selected columns will be adjusted to this same width! Click anywhere on the spreadsheet to remove the large selection.

12. When you finish entering the data (and adjusting columns B through D), insert a disk in the floppy disk drive and use the standard “Save” option from the “File” menu to save your spreadsheet up to this point on your disk with the same name as before (it should be “HOP5.xls” on drive A:).

**Part IV – Adding Formulas**

1. Select the first blank cell in column B (this should be cell B26). Type an equal sign (=). It should appear both in the cell and in the edit area of the formula bar.

2. Next, begin selecting a function for this formula by clicking on the “Insert Function” button. A highlighted function may appear in the edit area, but the “Function Wizard” dialog box will definitely appear. At this time, just ignore the function that appeared in the edit area (if any).

3. Click on “Math & Trig” in the “Function Category” pane (the left-hand pane) of the dialog box. A new list of functions should appear in the “Function Name” pane (the right-hand pane) of the dialog box, starting with “ABS”.

4. Use the scroll bar in the “Function Name” pane to scroll down until you can see the “SUM” function. Click on the “SUM” function (not the variants that start with “SUM”, just the simple “SUM” function). A highlighted template for the “SUM” function should appear in the edit area of the formula bar.

5. Click the “Next” button in the “Function Wizard” dialog box.

6. The “Function Wizard” dialog box will advance to step 2 of 2. Enter the cell range B4:B23 in the number1 blank, as shown: =SUM(B4:B23)

7. You should see the highlighted function in the edit area of the formula bar change accordingly. Click the “Finish” button in the “Function Wizard” dialog box.

8. The highlight will disappear in the edit area of the formula bar. This is all there is to this formula, so press “Enter” or click the accept button to finish the formula. You should see the formula disappear from the cell B26, and be replaced by the result of calculating the sum (which should be 1946). Note that the formula itself is still visible on the formula bar.

9. Click-n-drag to select cells B26, C26, and D26. Then click “Fill” from the “Edit” menu on the menu bar. A small side menu should appear, as shown. Click “Right” on this menu.

10. This will copy the formula from B26 into C26 and D26. Select C26 and D26 in turn, and note how the cell range in the formula automatically adjusted relative to the copy.

11. Enter the text label “Total Adjusted Price” into cell A26.

12. Select the cell in column A from the next row (should be cell A27), and add a text label of “Sales Tax Rate:” to this cell.
13. Select the next cell over (cell B27) and enter a value of 0.075 in this cell.
14. Select the cell in column A from the next row (should be cell A28), and add a text label of "Sales Tax Amount" to this cell.
15. Select the next cell over (cell B28). Type an equal sign (=). It should appear both in the cell and in the edit area of the formula bar.
16. Select the cell with the total adjusted price for Dell (cell B26) with the mouse. Notice how the cell reference is automatically added to your formula.
17. Press '*' on the keyboard to add a multiplication sign to the formula.
18. Select the cell with the sales tax rate (cell B27) with the mouse. Notice how the cell reference is again automatically added to your formula. Press "Enter" or click on the accept button to finish the formula.
19. Fill-right to copy the formula from B28 into C28 and D28. Note that the calculated amount of sales tax for Gateway 2000 and Midwest Micro is 0.
20. Select cell C28 and examine the formula placed in it. Write the formula here: ____________________.
21. Note that the reference for the total adjusted price for the Gateway system changed so that it was correct, but the reference for the sales tax rate changed too, even though it did not need to. This is because these are relative references (the default kind).
22. Select the cell with the original formula (cell B28). Click in the edit area of the formula bar, and put a dollar sign in front of both the row and the column of cell B27 (it should change to $B$27). This changes B27 to an absolute reference which will not change when copied.
23. Press enter to finish editing the formula.
24. Fill-right to copy the formula from B28 into C28 and D28. Note that the calculated amount of sales tax for Gateway 2000 and Midwest Micro is now correct.
25. When you finish entering the formulas, insert a disk in the floppy disk drive and use the standard "Save" option from the "File" menu to save your spreadsheet up to this point on your disk with the same name as before (it should be “HOP5.xls” on drive A:).

Part V – Formatting the Spreadsheet

1. Click-n-drag to select the column heading labels in cells B2-D2.
2. Click the centering button to center the text in these cells.
3. While cells B2-D2 are still selected, click the boldface button to boldface these cells.
4. While cells B2-D2 are still selected, click the italics button to italicize these cells.
5. Repeat steps 1-4 to center, boldface, and italicize cells A6-D6.
6. Select column A and click the boldface button to boldface all of its cells.
7. Boldface and italicize cells B1 and B5 (the "Base system..." and “Extra Charge...” headings).
8. Click-n-drag on the column headings to select columns B, C, and D.
9. Select “Format” on the menu bar and choose “Cells...”.
10. You should get a “Format Cells” dialog box. Click on the “Number” tab. Click “Currency” from the list. The dialog box should look like this.

11. Make sure that “Decimal Places” is set to 2.

12. Make sure that the “Use $” checkbox is checked.

13. Select the red numbers in parentheses for “Negative Numbers”.

14. Click “OK” to set the format. The dialog box should disappear, and show the formatted spreadsheet. Notice how numeric formats do not affect text cells, even though they are in the selected range.

15. Select the sales tax rate (cell B27). Notice that it has been set to currency as well, even though it is a percentage.

16. Select “Format” on the menu bar and choose “Cells…”.

17. You should get a “Format Cells” dialog box. Click on the “Number” tab. Click “Percentage” from the list, and choose 2 decimal places. Click “OK” to change the format.

18. When you finish formatting, insert a disk in the floppy disk drive and use the standard “Save” option from the “File” menu to save your spreadsheet up to this point on your disk with the same name as before (it should be “HOP5.xls” on drive A:).

Part VI – Printing the Spreadsheet and Finishing Up

1. Before we actually print, we want to see what the output will look like. So select “File” on the menu bar and choose “Print Preview”. You will see a miniature version of the page which shows the basic layout, but is not readable. This is called greeking. If you would like to see part of the page in full size, you can do so by moving the pointer onto the page, where it will appear as a magnifying glass, and clicking. Another click on the magnified page will restore it to the full-page view.

2. While still in the Print Preview window, click on “Setup…”. You should get a “Page Setup” dialog box with 4 section tabs:

3. Click on the “Page” tab. The spreadsheet will not fit across the short dimension of a piece of paper (called Portrait orientation), so we need to change it to Landscape orientation. Make sure that the radio buttons for “Orientation” are set to Landscape:

and that “Scaling” is set to Adjust to 100% of normal size:
4. Now click on the “Margins” tab. Check the “Center on Page” check boxes to center the spreadsheet both horizontally and vertically on the page:

5. Now click on the “Header/Footer” tab. You want to have your class, name, and today’s date print at the top of the printout, so click on the button.

6. You should get a “Header” dialog box, with three panes, one for “Left Section”, one for “Center Section” and one for “Right Section”. Delete whatever is currently in the “Left Section” pane, and enter your class number and section in its top line (so if you are in section 01, you should enter “CSCI 503-01”).

7. Delete whatever is currently in the “Center Section” pane, and enter your full name in its top line.

8. Delete whatever is currently in the “Right Section” pane, then click inside the “Right Section” pane and click the date button. “&[Date]” should appear on the right-hand side of the pane. This will cause the current date to be inserted at that position in the printout.

9. Click to finish editing the header. You should be back at the “Page Setup” dialog box, with a sample header similar to this (but with your own section, name, and date):

```
CS101A  |  Imma Student  |  11/286
```

10. Now click on the “Sheet” tab. We want the spreadsheet gridlines to show in the printout, so in the “Print” section, check the “Gridlines” check box:

11. Click in the “Page Setup” dialog box to finish setting up the printout. You should be back at the print preview window, and the preview page should look like this:

12. While still in the Print Preview window, click to print your spreadsheet.

13. Be sure to check your printed spreadsheet to make sure that it does have the proper centering, gridlines, and header with your class, section, name, and date.

14. Be sure to write your name, email address, section, and start/finish times on the top of this HOP. Staple the printout to this HOP, and turn it in to your instructor. You will also be required to take a short, multiple-choice quiz on your experience with this HOP at the same time. We will not take class time for this however, so you need to arrange to do it at some other time.